Information Technology Center, The University of Tokyo

Campus-wide Computing Research Division

Home > Campus-wide Computing Research Division > Services > WEB PARK > News > [Notice] Information on upgrading the PHP version used in Sakura Internet, and end of PHP5.6 security support

[Notice] Information on upgrading the PHP version used in Sakura Internet, and end of PHP5.6 security support

Created on September 27, 2018

Sakura Internet released an announcement stating that PHP will be upgraded from version 7.1 to 7.2 on October 3, 2018.

Please prepare for the upgrade in advance by confirming program operations, etc. as certain programs and CMS (WordPress, etc.) may be affected by the upgrade.

Please check the following support site for how to change PHP settings.

 ▼Upgrading PHP version
  https://help.sakura.ad.jp/hc/ja/articles/115000135681 (available only in Japanese)

It is possible to confirm the operation in advance using the staging server (testing environment) by using the “Backup & Staging” function.

 ▼Procedure for creating and deleting staging server for WordPress
  https://help.sakura.ad.jp/hc/ja/articles/360000150041 (available only in Japanese)

If any operation or other problems occur after initiating advanced verification, please address the problems.

If no problems are detected during the advanced verification, but a problem still occurs after completing the upgrade, it is possible to temporarily return to the previous version of PHP7.1.

 ※ Attention
  PHP7.1 will will no longer be available after January, 2019.
  We kindly ask users to prepare an environment capable of running on PHP7.2 services as soon as possible.

Please see the following support site for details on the PHP upgrade schedule and provider policy

 ▼PHP providing policy
  https://help.sakura.ad.jp/hc/ja/articles/360000115461

Please note that security support for PHP5.6 will end at the end of 2018 (support for PHP version under 5.4 have already ended). Please consider upgrading to the latest version as soon as possible.